absolinux

Sujet : Erreur au debut ... Binutils
posté par azmyth223 2 messages     le  15-09-2008  à  03:32citer
Bonjour

Sa part mal, une erreur a la compilation du premier paquet.

Lors de "configure" il me sort l'erreur suivante:

configure: error: can only configure for one host and one target at a time.

Je fait la commande configure qui est inscrite dans le livre LFS.

J'utilise le live cd de LFS 6.3 en machine virtuel ( VMware ) comme systeme hote.

Je suis debutant en linux j'aurais besoin de vos conseils et de votre experience.

merci

posté par Texou 271 messages     le  15-09-2008  à  14:45citer
Salut,

On t'enverra un complément  de  réponse d'ici peu. En attendant, quelle version du livre suis-tu? 6.3? svn?
Ensuite, je crains (à vérifier) que cela vienne du fait que tu passes par une machine virtuelle. La virtualisation du CD pose peut-être souci. Tu essaies d'installer lfs sur le disque de ta machine virtuelle donc?

Avec tes 2 réponses on pourra mieux savoir.

À+ et bon courage

_______________________

Texou
Coadministrateur du projet absolinux
Président de l'association traduc.org
Coordinateur du projet Linux From Scratch
Coordinateur au sein du projet Trad GNU de l'April
Animateur suppléant du groupe de travail Accessibilité de l'April
posté par azmyth223 2 messages     le  15-09-2008  à  16:14citer
La version du livre est : Version SVN-20080711. Oui j'installe le tout sur un disque virtuel faute de matériel physique.

J'ai lu qu'il y avait des erreurs avec la virtualisation et le livecd, mais je me suis essayer quand même... de toute évidence c'étais pas une bonne idée... héhé

Merci

Yannick
posté par Texou 271 messages     le  15-09-2008  à  16:19citer
À vérifier dans peu mais je crains  que en effet, la virtualisation pose des soucis. J'espère queqqn pourra me compléter.
À+ JP
_______________________

Texou
Coadministrateur du projet absolinux
Président de l'association traduc.org
Coordinateur du projet Linux From Scratch
Coordinateur au sein du projet Trad GNU de l'April
Animateur suppléant du groupe de travail Accessibilité de l'April
posté par dizzux 3 messages     le  02-11-2008  à  13:21citer
Salut,

je suis actuellement entrain d'installer lLFS 6.3 sur virtualbox, je rencontre un probleme également sur binutils,

je ne sais pas si cela viens de la virtualisation ou d'une erreur de ma part.

Section 5.3 donc je tape la commande:
CC=".. etc "
puis make et la :

make: *** No targets. stop

j'ai decompresse binutils-2.17 dans /mnt/lfs/sources/binutils-build.

si vous pouvez m'aider . Merci

@+
posté par Texou 271 messages     le  02-11-2008  à  13:59citer
Salut,

Déjà il nous faudrait quelques précisions: donne-nous davantage de lignes renvoyées par make. Comme l'explique le livre, l'envoi de la dernière ligne ne suffit pas à nous faire comprendre ce qui ne marche pas.

Ensuite, soit j'ai mal compris soit tu commets une erreur. Binutils ne se décompresse pas dans binutils-build. Il se décompresse, tu vas dedans, là, après d'éventuels correctifs (uniquement si le livre le dit), tu fais mkdir ../binutils-build puis cd ../binutils-build, bequel est donc vide à l'origine. D'où les commandes après .../binujils-version/commande.

Voilà 2 1ères pistes. À suivre :)

Bon courage at a+

_______________________

Texou
Coadministrateur du projet absolinux
Président de l'association traduc.org
Coordinateur du projet Linux From Scratch
Coordinateur au sein du projet Trad GNU de l'April
Animateur suppléant du groupe de travail Accessibilité de l'April
posté par dizzux 3 messages     le  04-11-2008  à  20:16citer
Bonsoir,

En effet, j'ai modifier la manière de créer binutils-builds et j'ai donc créé ce fichier dans binutils-2.17 fraichement décompressé.

Pour ce qui est du renvoie de make: il y a juste cette ligne
make: *** No targets. Stop.

j'ai pu remarquer que au début de ma commande CC="etc.." cela me renvoie:
loading hosconfig.cache
checking host systeme type... config.sub: invalid option --prefix=/tools
Try 'config.sub' --help' for more informations.

cela me fait trois ligne comme çà puis une ligne:

checking for a BSD compatible install...(cached) /usr/bin/install -c
checking whether In works... (cached) yes

enfin après il y a plein d'autres checking...

bon je cherche de mon coté si vous avez des pistes

@+
posté par boloco 85 messages     le  04-11-2008  à  23:16citer
Salut, la sortie de configure: invalid option --prefix=/tools fait penser que le lien symbolique /tools n'a peut-être pas été créé. la commande est ln -sv $LFS/tools /
[smile]
posté par dizzux 3 messages     le  05-11-2008  à  20:06citer
j'ai bien créé le lien comme sur le livre parce que quand je retape la commande il me dit qu'il est déjà créé.

Par contre savez-vous ce qu'est le fichier config.sub parce que il me demande de faire try config.sub --help.

je crois que c'est un lien vers libtool

bon je cherche tjrs

@+

REDIT

Comme je pensé que c'était l'option --prefix=/tools qui me posé des problèmes je l'ai supprimer pour voir mais cela me faisais la même erreur avec les --disbale alors j'ai levé toutes les option et cela a marché.

Mais biensur je n'ai pas demandé à configure de se préparer à installer dans /tools.

Est ce que je peux faire maintenant un make -C $LFS/tools ?

@+




répondre