absolinux

Sujet : BLFS Chapitre 32. Bureau Xfce -> thunar-volman-0.8.0 -> udev-Version LFS ou udev-extras
posté par loreleil 20 messages     le  23-01-2014  à  15:41citer
Salut,

Dépendances de Thunar Volume Manager a dit :


[B]Requises[/B]

exo-0.10.2, libxfce4ui-4.10.0 et udev-Version installée par LFS [B]ou[/B] udev-extras (from systemd) ([B]pour gudev[/B])..



Dépendances d'éxécution recommandées a dit :


gvfs-1.16.3 et polkit-gnome-0.105


En remontant la chaîne des dépendances (Requises et Recommandées incluses) de gvfs-1.16.3 http://lfs.traduc.org/view/blfs-7.4-fr/gnome/gvfs.html j'arrive  au paquet UDisks-2.1.1. http://lfs.traduc.org/view/blfs-7.4-fr/general/udisks2.html

Nota : je ne cite que les paquets incriminés directement (à mon sens) lors de la compile de ce dernier.

La pré-compile me retourne l'erreur suivante :

./configure a dit :

[14:00:40] ~/Xfce/udisks-2.1.1 $ ./configure --prefix=/usr        \
>            --sysconfdir=/etc    \
>            --localstatedir=/var \
>            --disable-static
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes

...

checking pkg-config is at least version 0.9.0... yes
checking for gtkdoc-check... no
checking for gtkdoc-rebase... no
checking for gtkdoc-mkpdf... no
checking whether to build gtk-doc documentation... no
checking for xsltproc... (cached) /usr/bin/xsltproc
checking for gobject-introspection... yes
[B]checking for GUDEV... no
configure: error: Package requirements (gudev-1.0 >= 165) were not met:

No package 'gudev-1.0' found[/B]

[U]Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.[/U] [B] #### ?[/B]

[U]Alternatively, you may set the environment variables GUDEV_CFLAGS
and GUDEV_LIBS to avoid the need to call pkg-config.[/U] [B]### ?[/B]
See the pkg-config man page for more details.
[14:01:26] ~/Xfce/udisks-2.1.1 $



[15:56:21] ~/Xfce/udisks-2.1.1 $ ls
acinclude.m4  config.guess  config.sub    COPYING  doc          install-sh  Makefile.in  po      test-driver
aclocal.m4    config.h.in  configure    data    gtk-doc.make  ltmain.sh    missing      README  tools
AUTHORS      config.log    configure.ac  depcomp  HACKING      Makefile.am  NEWS        src    udisks
[15:56:23] ~/Xfce/udisks-2.1.1 $



[15:27:43] ~/Xfce/udisks-2.1.1 $ /sbin/udevadm --version
206
[15:27:46] ~/Xfce/udisks-2.1.1 $



[15:55:59] ~/Xfce/udisks-2.1.1 $ echo $XORG_CONFIG
--prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-static
[15:56:00] ~/Xfce/udisks-2.1.1 $ echo $XORG_PREFIX
/usr
[15:56:05] ~/Xfce/udisks-2.1.1 $



Qu'est-ce que gudev-1.0 vient faire là ???

http://lfs.traduc.org/view/blfs-7.4-fr/gnome/gvfs.html


Recommandées a dit :

GTK+-3.8.4, ... udev-Version installée par LFS [B][U]OÙ[/U][/B] udev-extras (from systemd) ([U]pour GUdev[/U]) et UDisks-2.1.1



Je crois avoir résumé la situation ... [ange]
posté par loreleil 20 messages     le  24-01-2014  à  11:15citer
Salut,


Solution qui me fût donnée par appzer0 sur le salon (#lfs-fr)


appzer0 a dit :

donc si tu veux libgudev, il te faut glib puis recompiler udev



Dans mon cas, il suffisait de recompiler udev.

http://lfs.traduc.org/view/blfs-7.4-fr/general/udev.html

appzer0 Merci !

Je t'en serre cinq. [wink]




répondre