absolinux

Sujet : BLFS - Gnome
posté par pouypouy 21 messages     le  14-10-2012  à  16:55citer
Bonjour à tous,

J'essaie d'installer gnome - histoire d'avoir un bureau un peu plus complet

Toutes les bibliothèques et coeurs s'installent parfaitement - sauf gnome-shell

Lors du configure, il ne trouve pas le paquet gjs-internals-1.0

En regardant les paquets présents dans blfs, je ne vois qu'un seul qui puisse correspondre, avec les dépendances obligatoires, à savoir, le paquets gjs-1.34.0

Le configure ne pose pas de problème mais lors de la construction le make s'arrête avec comme erreur :
/usr/bin/ld: cannot find -lmozjs185

le lancement de startx avec gnome me marque "failed to load session "gnome" " du coup

J'ai essayé avec d'autres version de gjs mais même résultat du make

Quelqu'un aurait-il une solution ?

Bien cordialement,

patrick
posté par Myou 99 messages     le  14-10-2012  à  18:11citer
Bonjour,

Alors oui le paquet gjs-1.34.0 est une dépendance obligatoire de gnome-shell, il faut donc l'installer avant.

Pour installer gjs-1.34.0 il faut aussi installer ses dépendances obligatoires. On retrouve spidermonkey, qui selon mes recherches fourni mozjs185.

Il semble donc que spidermonkey ne soit pas (correctement ou pas du tout ;o) ) installé sur ton système.

Cordialement

Denis @ Myou
Coordinateur traduction BLFS
posté par pouypouy 21 messages     le  15-10-2012  à  09:43citer
Bonjour,

Le problème devait bien venir de spidermonkey - que j'avais pourtant bien installé - peut être une erreur de frappe au niveau du sed - tout fonctionne

Merci pour l'aide
posté par pouypouy 21 messages     le  05-12-2012  à  20:22citer
Bonsoir,

Je continue mon post - car nouveau problème sous gnome (ou plutôt xorg)

je n'arrive pas à avoir un clavier en azerty au démarrage de l'interface - j'ai beau connaître à peu près le clavier qwerty c'est un peu embêtant. Je suis donc obligé de taper dans une console setxkbmap fr à chaque démarrage.

Je n'ai aucun problème sur les consoles virtuels - seulement sur le mode graphique.

Peut-on, comme sous certaines distribution créer des fichiers du genre 10-* sous /etc/X11/xorg.conf.d et si oui, comment faire pour que le système les utilise ??

J'ai cherché mais n'ai rien trouvé - peut être mal cherché mais cela fait 5 soirs que je suis sur ce problème. j'ai essayé de mettre une commande setxkbmap fr dans .xinitrc mais cela ne sert à rien

Cordialement,
posté par boloco 85 messages     le  05-12-2012  à  21:58citer
bonsoir,
pour la configuration de xkb, la solution se trouve dans le livre, ici: http://lfs.traduc.org/view/blfs-20121101/x/xorg-config.html#xconfig
Il faut y rajouter l'option "XkbLayout" "fr" afin d'avoir le clavier azerty




répondre