absolinux

Aller à la page : 1 2 3 4 5 6 suivante

Sujet : grub erreur 13 après reboot.
posté par AndreAni 42 messages     le  09-10-2012  à  15:59citer
Bonjour,

Bon, après avoir fini LFS 7.2, sans erreur particulière, je redémarre, et erreur 13 de grub.
Je ne sais pas trop quoi faire ni comment...

Si quelqu'un a une idée je suis preneur.
Merci d'avance,
Très cordialement,

AndreAni

_______________________

Gnu Linux et Logiciels Libres
http://andre-ani.fr
posté par Texou 271 messages     le  09-10-2012  à  20:33citer
Salut,

On n'est guère plus avancés que toi si tu t'en tiens à ce message. :) Que se passe-t-il exactement? qu'affiche l'écran? quand au démarrage (au début, etc.)? Il faut les 5-10 dernières lignes de l'écran pour commencer à réfléchir.

Selon toute vraisemblance et d'expérience, ça doit être un souci noyau. Soit tu as mal configuré GRUB, soit fstab, soit le noyau (les drivers du disque dur et du système de fichiers de la partition racine sont en dur ou en module? etc.). Bref ces 3 pistes (mais surtout le noyau) sont à creuser.

Amitiés,

_______________________

Texou
Coadministrateur du projet absolinux
Président de l'association traduc.org
Coordinateur du projet Linux From Scratch
Coordinateur au sein du projet Trad GNU de l'April
Animateur suppléant du groupe de travail Accessibilité de l'April
posté par AndreAni 42 messages     le  10-10-2012  à  03:45citer
Je vais essayer d'être plus précis alors [wink]

Au démarrage de la machine, j'ai grub qui s'affiche, me proposant uniquement LFS.
Et juste après avoir choisi LFS, j'ai le message d'erreur 13 de grub qui s'affiche, invalid or unsupported executable format.

Je pense aussi que cela vient du noyau, j'ai du faire une bêtise, mais je ne suis pas un pro du kernel, j'ai fais la config plutôt "au pif"...

Voila pour les précisions.
Je suppose que je peux repasser en chroot, et refaire la compile du kernel ? Voir aussi l'install de grub ?

Merci pour l'aide [wink]
Très cordialement,

ANDRE Ani
_______________________

Gnu Linux et Logiciels Libres
http://andre-ani.fr
posté par Myou 99 messages     le  10-10-2012  à  12:49citer
Bonjour,

Avant de refaire le noyau, peux tu donner ton fichier de config de grub et aussi nous en dire plus sur tes partitions ?
comment s'appelle celle de démarrage, celle ou LFS est installée ?

Tu as utilisé quoi comme distribution hôte ? je suis surpris par ton "Au démarrage de la machine, j'ai grub qui s'affiche, me proposant uniquement LFS."
Si tu as utilisé un live Cd pour construire, c'est bon, sinon c'est louche ;o)

Cordialement

Denis M
Coordinateur traduction BLFS
posté par AndreAni 42 messages     le  10-10-2012  à  15:56citer
Alors, voici des précisions :

distro hote : Mageia 2.

le fichier de conf /boot/grub/grub.cfg

set default=0
set timeout=5
insmod ext2
set root=(hd0,3)

menuentry "GNU/Linux, Linux 3.5.2-lfs-7.2" {
        linux  /boot/vmlinuz-3.5.2-lfs-7.2 root=/dev/sda3 ro
}


mes partitions :

sda1 windows
sda2 swap
sda3 lfs
sda4 mageia

Pour le démarrage, j'ai cafouillé un peu, j'avais viré mon grub pour celui de lfs, mais j'ai remis celui de Mageia 2. Puis essayé d'ajouter lfs depuis le CCM de Mageia 2 mais tjs la même erreur.

Voila, si ça peut vous aider à trouver le pbm.

Merci d'avance,
Très cordialement,

ANDRE Ani

_______________________

Gnu Linux et Logiciels Libres
http://andre-ani.fr
posté par Myou 99 messages     le  10-10-2012  à  19:11citer
Merci pour les précisions.

Donc pour refaire une bref explication sur GRUB. Le gestionnaire de démarrage (GRUB, mais il y en a d'autres) n'est pas dépendant du système.
IL NE FAUT DONC PAS LE REINSTALLER SUR LFS QUAND ON EN A DEJA UN D'INSTALLER !!!

en lisant ton grub.cfg (d'ailleurs c'est le rep boot de mageia ? lfs ?), je pense que ton pc ne doit plus démarrer puisque seulement lfs est déclaré.

Peux tu me confirmer que tu ne peux plus le démarrer ?

Si oui, la marche à suivre est de trouver un live-CD et de réinstaller GRUB qui va trouver tes 3 systèmes (mageia LFS et windows).

GRUB doit être installé sur la partition qui est déclarée celle de démarrage.

JE viens de relire, et donc j'ai la confirmation que c'est le pb que tu avais ;o).. mais tu as remis le grub depuis mageia et normalement il aurait du voir aussi ta LFS.

qu'appelles tu le CCM de mageia2 ? (je ne connais pas cette distrib)/

Normalement depuis mageia faire un grub-update (ou équivalent) doit lui faire trouver tes 3 systèmes.

Cordialement

Myou
Coordinateur traduction BLFS
posté par boloco 85 messages     le  10-10-2012  à  19:34citer
Salut, AndreAni

mageia2 utilise grub-0.97, tandis que lfs-7.2 utilise grub2. Les deux ne sont pas compatibles. Il y a donc plusieurs solutions à ton problème ;)
posté par Myou 99 messages     le  10-10-2012  à  19:55citer
Merci de l'info boloco, je ne savais pas (ne connaissant pas mageia).

Juste Andre, je te précise que grub2 n'est absolument pas obligatoire à LFS, LFS peut très bien démarrer depuis grub 0.97.

A+

Myou
posté par AndreAni 42 messages     le  11-10-2012  à  04:31citer
Alors, c'est grub.cfg de lfs la. J'ai réparé avec le CD de Mageia 2 mais il n'a pas ajouté lfs au boot.

Le ccm, c'est le centre de contrôle (Mageia est le fork de Mandriva), ou on peut tout configurer.

Et oui, je savais pour les incompatibilités des 2 versions de grub, j'y ai plus pensé la, mais j'ai déjà eu le soucis entre d'autres distros.

update-grub : command not found, depuis Mageia 2.
Alors j'ai ajouté lfs depuis le ccm, mais tjs pareil.

Devrais-je désinstaller grub de lfs, et si oui comment ?

Je sais plus trop quoi faire la...


_______________________

Gnu Linux et Logiciels Libres
http://andre-ani.fr
posté par Myou 99 messages     le  11-10-2012  à  12:47citer
Dans ton cas, inutile d'installer grub sur LFS.
Donc sur ta LFS tu pourras enlever les fichiers ajoutés par grub, ils ne servent à rien ;o)

Maintenant, il faut faire reconnaitre à grub 0.97 (dont le fichier de config menu.lst est dans mageia) ta LFS.

Je ne connais pas le ccm de mageia.

boloco pourra t'aider sur ce point ;o)

Myou



Aller à la page : 1 2 3 4 5 6 suivante