absolinux

Sujet : LFS - Configuration de Grub (ou erreur dans le kernel ??)
posté par pouypouy 21 messages     le  20-07-2012  à  19:30citer
Bonjour à tous,

Après la construction de LFS sur mon vieux portable, j'ai voulu essayer sur le fixe - un système 64bits mais en utilisant les commandes de LFS simple.

Toute la construction se passe sans problème, je compile le kernel sans problème, et j'arrive à la configuration de grub. Je crée le grub.cfg et redémarre et là j'ai un magnifique KERNEL PANIC

je rajoute après recherche sur le net une option à la ligne de commande (raid=noautodetect) mais idem

voici les dernières lignes du lancement :
BIOS EE facility v0.16 2004-Jun-25, 0 devices found
EDD information not available.
input: AT translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input2
mk: skipping autodetection of RAID arrays. (raid=autodetect will force)
VFS: Connot open root device "sda" or unknwn-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknow-block(0,0)
Pid: 1, comm: swapper/0 Not tainted 3.2.6 #2
Call Trace!7panic+0x91/0x1a7
mount_block_root+0x1d1/0x283
? name_to_dev_t+0x770/0xe40
mount_root+0x53/0x57
prepare_namespace+0x16d/0x1a6
? release_tgcred.isra.4+0x30/0x30
kernel_init+0x145/0x14a
kernel_thread_helper+0x4/0x10
? start_kernel+0x3c5/0x3c5
? gs_change+0x13/0x13


Je me rends bien compte qu'il ne trouve pas la partition racine : j'ai fais simple :
une partition swap sur /dev/sda3
une partition / sur /dev/sda4 et sur laquelle sont tous les répertoires
le fstab a bien en root la partition (hd0,4)
      sinon cela ne se lancerait même pas
et sur la ligne de commande de lancement le root= pointe bien sur /dev/sda4

Ais-je loupé quelque chose dans la configuration du kernel ? est-ce un problème dans la configuration de grub ? Mon disque est a priori branché sur un port SCSI Disk Device. Que faudrait-il que je change ??

Merci pour toute aide,

Bien cordialement.
posté par Texou 271 messages     le  20-07-2012  à  22:00citer
Salut,

N'hésite pas à passer sur IRC pour ce genre de pb complexe à résoudre, car ça dépend sûrement d'une option du noyau. #lfs-fr est sur freenode.net.

Sur le fond (et avant), regarde si tu as bien activé, en dur, le driver du chipset du disque dur, le SATA et les paramètres liés à la connectique du disque dur (SCSI etc.). Enfin, les systèmes de fichiers sont-ils en dur? Car en module, c'est potentiellement non opérationnel. Enfin revérifie bien que GRUB va bien sur la partition racine.

Tiens-nous au courant,

_______________________

Texou
Coadministrateur du projet absolinux
Président de l'association traduc.org
Coordinateur du projet Linux From Scratch
Coordinateur au sein du projet Trad GNU de l'April
Animateur suppléant du groupe de travail Accessibilité de l'April
posté par pouypouy 21 messages     le  20-07-2012  à  22:12citer
salut,

je revérifierai demain mais je crois bien avoir fais en sorte de mettre en dur les paramètres qui me semblaient être dans mon matériel.

Je passerai sur l'irc si jamais c'est bien le cas - merci pour l'aide

posté par pouypouy 21 messages     le  29-07-2012  à  19:03citer
Bonsoir à tous,

Ce petit mot pour vous signaler que j'ai bien finis l'installation de lfs-7.1 (merci encore à la personne qui m'a passé le .config du kernel).

Depuis, j'ai installé tout ce dont j'avais besoin pour travailler :
- Xorg avec XFCE ;
- gimp ;
- xchat et firefox
Le système fonctionne parfaitement - peut être ais je installé des choses que je n'utiliserai jamais mais ce n'est pas grave - le système est fonctionnel - et même NFS fonctionne pour accéder à mes fichiers

Je ne pense pas refaire une telle installation avant longtemps (peut être pour la 8.0) - et les changements très majeurs - car c'est long mais vraiment très intéressant - surtout pour la compréhension de X - on se doute pas de toutes les subtilités des configurations du système graphique

Encore merci pour l'aide

Cordialement,

Pouypouy
posté par Texou 271 messages     le  29-07-2012  à  20:19citer
Salut,

Ce message nous fait très plaisir et nous t'en remercions. C'est un des retours les plus intéressants et encourageants qu'on ait eu depuis longtemps. Merci à toi et j'espère que tu seras content de ton expérience LFS.

A bientôt,



_______________________

Texou
Coadministrateur du projet absolinux
Président de l'association traduc.org
Coordinateur du projet Linux From Scratch
Coordinateur au sein du projet Trad GNU de l'April
Animateur suppléant du groupe de travail Accessibilité de l'April




répondre