absolinux

Sujet : Des logs dans tty qui n'ont rien à faire là !
posté par maxlamenace 11 messages     le  11-06-2012  à  21:34citer
Bonsoir,

Je viens vous voir parceque j'ai un léger soucis. C'est plus un problème "esthétique" qu'autre chose.

J'ai installé une LFS (7.1) récemment. Tout marche nickel ! Mais un message s'affiche sur la tty quand je branche ma souris USB (juste elle). C'est sûr pour l'instant ma souris en console, c'pas très utile. Mais j'aimerais rediriger le message de connexion/deconnexion de la souris ailleur (dans un fichier). Mais le problème c'est que ce message ne vient pas de ma configuration de syslog.

Le log du kernel sont redirigés vers /var/log/kernel.org

Alors je ne comprend qu'est-ce qui provoque ces messages. Et je vous avoue que pour rediriger un message sans savoir d'où ça vient c'est pas évident. Surtout que ça me le fait qu'avec ma souris...

Alors je me tourne vers vous en espérant trouver une solution (ou un début de solution).

Merci

[B]Mon message quand je branche la souris :[/B]
[ 1132.457209 ] usb 2-1.3: new low-speed USB device number 7 usign ehci_hcd
[ 1132.549812 ] input : PIXART USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3/2-1.3:1.0/input/input12
[ 1132.549956 ] generic-usb 0003:093A:2510.0005: input,hidraw0: USB HID v1.11 Mouse [PIXART USB OPTICAL MOUSE] on usb-0000:00:1d.0-1.3/input0

[B]Quand je débranche :[/B]
[ 1137.400415 ]usb 2-1.3: USB disconnect, device number 7
posté par Texou 271 messages     le  12-06-2012  à  01:34citer
Salut,

Avant d'appeler l'artillerie lourde (connaisseurs du noyau), j'émets une hypothèse. J'ai le même problème sur une distribution plus classique (Debian). C'est dû, je pense, à la configuration du noyau. Dans ton menuconfig, regarde dans Devices, la section sur l'USB. Regarde si une option genre USB log level ou USB log, notamment près de "USB mouse" est compilée en dur ou pas. À mon avis c'est là qu'il faut taper. Il faut décocher la bonne option dans menuconfig, celle qui génère les logs USB.

Espérant t'aider. Tiens-nous au courant.


_______________________

Texou
Coadministrateur du projet absolinux
Président de l'association traduc.org
Coordinateur du projet Linux From Scratch
Coordinateur au sein du projet Trad GNU de l'April
Animateur suppléant du groupe de travail Accessibilité de l'April
posté par maxlamenace 11 messages     le  12-06-2012  à  09:21citer
Salut,

Merci de répondre aussi vite ! :p

Et bien j'avais cherché dedans, j'avais trouvé une ligne USB verbose debug message et USB announce new devices. Je les ai décoché, mais ça n'a absolument rien fait.

De plus j'ai pas de ligne qui ressemble de près ou de loins à USB mouse. Aussi bien dans HID Devices que dans USB support.

Par contre, si c'est bien dans la configuration du noyau, le fait que les log kernel soit dans /var/log/kernel.log ne devrait il pas afficher ça dans ce fichier plutôt que sur le tty ?

Merci
posté par Myou 99 messages     le  12-06-2012  à  18:13citer
Bonjour,

J'ai eu il n'y a pas longtemps un problème identique avec les messages iptables. Des qu'un paquet était logué, il s'affichait sur la console (quand le fw ne laisse rien passer, la console se rempli très vite !!!  ;;o) ).

Il y a plusieurs solutions

1 - dans /etc/init.d/sysklogd
tu peux modifier l'appel à klogd avec l'argument -c 3 par ex (voir man klogd pour les valeurs)

tu auras donc dans le fichier sysklogd un truc du genre :

    log_info_msg "Starting kernel log daemon..."
      start_daemon /sbin/klogd -c 3
      evaluate_retval
      ;;

2 - utilisation de dmesg -n 1. Voir man dmesg.


Voila j'espère que cela t'aidera.

Denis
posté par maxlamenace 11 messages     le  12-06-2012  à  22:04citer
Re,

Merci myou, t'as solution a marche nickel !

Max
posté par Myou 99 messages     le  13-06-2012  à  08:55citer
Re,

Content d'avoir pu t'aider alors.

Denis




répondre