absolinux

Sujet : LFS - problème de compilation
posté par vewo 4 messages     le  25-04-2012  à  20:03citer
Bonjour !
Ça fait un petit moment que je bloque au chap 5.4 de LFS, parce que je n'arrive pas a compiler Binutils ... Je suis sur que c'est tout bete mais comme je ne m'y connais pas bcp en compilation ... [bof]
Et mes recherches sur google n'ont rien données, donc je viens chercher de l'aide ici [smile]

Je copie le probleme:
lfs binutils-2.22 > ./configure \
> --target=$LFS_TGT --prefix=/tools \
> --disable-nls --disable-werror
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-lfs-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln works... yes
checking whether ln -s works... yes
checking for a sed that does not truncate output... /bin/sed
checking for gawk... gawk
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: in `/media/lfs/binutils-build/binutils-2.22':
configure: error: C compiler cannot create executables
See `config.log' for more details.


... et le config.log et ici http://pastebin.com/SvYHsMMr (il est un peu long ^^)

Voila, je n'ai plus qu'a attendre ... [bigsmile]


_______________________

Gnome Shell sur une ArchLinux toute fraiche !
Et le tout sur un Dell Vostro V130

Et bien motivé pour l'aventure LFS :D
posté par Myou 99 messages     le  30-04-2012  à  21:23citer
Bonjour

En regardant le config.log on trouve
gcc version 4.7.0 20120414 (prerelease) (GCC)
configure:4018: $? = 0
configure:4007: gcc -V >&5
gcc: error: unrecognized command line option '-V'
gcc: fatal error: no input files

ton compilateur n'aime pas l'option -V et un peu plus loin une autre option également...

Est ce que le pb ne viendrait pas de ta version de GCC qui est trop récente. D'ailleurs le livre, il me semble déconseille l'utilisation des versions de GCC supérieures à 4.6.0.

Peux tu essayer avec une version de GCC inférieure à 4.6.0 ?

Amitiés

Denis
posté par vewo 4 messages     le  30-04-2012  à  21:25citer
Ha oui c'est vrai > <
C'est la première fois qu'on me dit que ce que j'ai est 'trop récent' ^^
Je vais tester ça tout de suite ! Merci ! [bigsmile]
_______________________

Gnome Shell sur une ArchLinux toute fraiche !
Et le tout sur un Dell Vostro V130

Et bien motivé pour l'aventure LFS :D
posté par piernov 3 messages     le  30-04-2012  à  22:59citer
Bonjour,
Je me permets de corriger Myou en signalant qu'une erreur dans le configure n'aboutit pas forcément à un échec. Ici l'erreur sur l'argument -V sert justement à vérifier à quel type de compilateur configure a à faire, on peut donc l'ignorer.
La véritable erreur se situe elle au niveau de la compilation du programme de test.
"gcc: error trying to exec 'as': execvp: Too many levels of symbolic links"
Celle ci signifie au choix qu'il y a trop de lien symbolique avant d'aboutir au bianire as, ou alors (plus probable), une boucle dans un lien symbolique.
Il se peut aussi que le binutils de l'hôte soit cassé.
Enfin, GCC 4.7.0 ayant subit beaucoup de modification il n'est pas vraiment  recommendé de l'utiliser en sortant du cadre de LFS. (enfin l'erreur ici présente n'est normalement pas causé par l'utilisation de cette version).
_______________________

//piernov
posté par vewo 4 messages     le  30-04-2012  à  23:18citer
Ha bon ? Bah pourtant il me semble que je ne suis pas sortit du cadre O.o
Bah je vais tout recommencer j'était pas hyper loin ^^'

Et pour la version trop récente, j'ai voulu la rétrograder mais j'ai 30 000 soft qui dépendent de gcc 4.7 donc ...

Merci de vos conseils ! [smile]
_______________________

Gnome Shell sur une ArchLinux toute fraiche !
Et le tout sur un Dell Vostro V130

Et bien motivé pour l'aventure LFS :D




répondre