absolinux

Sujet : problème 5.7.1. Installation de Glibc
posté par belgariel 7 messages     le  11-12-2009  à  11:00citer
Bonjour,

Au début de la partie 5.7.1 sur l'installation de Glibc, il est marqué d'exécuter les commandes suivantes :

cp -v nptl/sysdeps/unix/sysv/linux/i386/i486/lowlevellock.S{,.orig}
sed -e 's/FUTEX_WAIT\( | FUTEX_CLOCK_REALTIME, reg\)/FUTEX_WAIT_BITSET\1/' \
        <nptl/sysdeps/unix/sysv/linux/i386/i486/lowlevellock.S.orig \
        >nptl/sysdeps/unix/sysv/linux/i386/i486/lowlevellock.S


Le problème est que je ne vois pas à partir d'où les exécuter.
Je n'est pas trouvé le répertoire nptl.
posté par TrueDD 97 messages     le  12-12-2009  à  00:53citer
Salut belgariel,

Comme pour les autres paquets que tu as déjà dû construire à cette étape, tu as bien décompressé l'archive glibc-2.10.1.tar.bz2, ce qui t'a généré le répertoire glibc-2.10.1 dans lequel tu trouveras ton fameux nptl.

Tes commandes sont donc à saisir dans ce répertoire là. (glibc-2.10.1)


sources$ tar xvf glibc-2.10.1.tar.bz2
glibc-2.10.1/
glibc-2.10.1/elf/
glibc-2.10.1/elf/dl-runtime.c
....
....
glibc-2.10.1/iconv/iconv_prog.c
glibc-2.10.1/iconv/iconv_open.c
glibc-2.10.1/iconv/gconv_cache.c
sources$ cd glibc-2.10.1
sources/glibc-2.10.1$ cp -v nptl/sysdeps/unix/sysv/linux/i386/i486/lowlevellock.S{,.orig}
`nptl/sysdeps/unix/sysv/linux/i386/i486/lowlevellock.S' -> `nptl/sysdeps/unix/sysv/linux/i386/i486/lowlevellock.S.orig'
sources/glibc-2.10.1$ sed -e 's/FUTEX_WAIT\( | FUTEX_CLOCK_REALTIME, reg\)/FUTEX_WAIT_BITSET\1/' \
        <nptl/sysdeps/unix/sysv/linux/i386/i486/lowlevellock.S.orig \
        >nptl/sysdeps/unix/sysv/linux/i386/i486/lowlevellock.S

sources/glibc-2.10.1$



Bonne continuation [smile]


_______________________

Retrouvez-nous sur le canal #absolinux (serveur irc.freenode.net) [smile]




répondre

http://med4treat.top